Leaderboard Extra
IRON MAN Blu-ray Problems?

Forums - Discs & Movies - IRON MAN Blu-ray Problems? 

1st October 2008 5:11  #1

flicster Member Join Date: May 2005 Location: United States Posts: 125
I just picked up Iron Man on Blu-ray and popped it into my PS3 to watch and it doesn't seem to be working (even after downloading the latest update) -- I was wondering if anyone else is having the same problem. Basically what appears to be a load screen (featuring the Iron Man chest light gadget thing) appears and blinks. This continues for a lot longer that I would expect a Load Screen to take. Any help would be much appreciated.

Nevermind everyone! I just tried it again, this time letting it go and, after a few minutes, it suddenly. finally kicked in and loaded. It now seems to be working fine. Hopefully it was just a fluke glitch.

1st October 2008 11:56  #2

BoBoi Member Join Date: June 2005 Location: Australia Posts: 1,109 Send a message via MSN to BoBoi Send a message via Yahoo to BoBoi
Nice to know you finally able to play this - there has been a wide report for discs that got out earlier than the Release Date seems to have manufacturing problems and doesn't play with some player i.e. S300 etc, all the disc since then has been called (like last week).

Paramount aimed to replace all the disc to meet yesterday's Release Date, I believe they more or less did, mine has been shipped from Amazon, guess I'll find out rather soon how this one turns out 'Wink

1st October 2008 12:05  #3

Cinque Member Join Date: June 2007 Location: United States Posts: 674
Just want to pass this little bit of info along to any more PS3 owners who might still be having problems with playing Iron Man.  Try going to the Blu-ray Settings Menu and changing the Internet Connection Option to Confirm.  Next time you queue up the disc, a prompt should appear on the screen asking if you would like to connect to the internet for BD-Live updates.  Choose No and the movie should start up like normal......  

1st October 2008 13:51  #4

Intergalactic Ponce Member Join Date: April 2005 Location: United Kingdom Posts: 1,151
I had this with Transformers (a BD Live title) and the 1st play took about 3-5 mins to finally start. Just had LOADING onscreen for that time. Presumably the disc and player were 'speaking' to the 'live' part over on whatever server BD Live comes from before playing as normal. Since then, Transformers loads like any other BD between 5 and 10 seconds on PS3.

1st October 2008 14:40  #5

Disciple Member Join Date: April 2006 Location: Sweden Posts: 765
I got mine like a week or so before the release and i've had no problems playing the discs on my Samsung BD-P1400 player. There was one time when the "chest light gadget thing" was still on screen when i got to the main menu, but it soon disappeared.

1st October 2008 16:36  #6

Franchise Member Join Date: March 2006 Location: United States Posts: 294 Send a message via AIM to Franchise Send a message via MSN to Franchise Send a message via Yahoo to Franchise
I had the same issue as well.  I was a bit pissed by it because I bought the Target exclusive collectible packaging and didn't want to return it.  I let it go for about 10 minutes and then restarted.  Knowing that the discs were defective from something I read last week, I was so mad that I just restarted it and it started fine.

1st October 2008 18:19  #7

SlimPickins Member Join Date: March 2008 Location: United States Posts: 54
Some of the copies at Best Buy were defective, but the defective ones should have been pulled off the shelves as of yesterday.

SKU 9025093 are defective.
SKU 9078981 should be fine.

2nd October 2008 0:43  #8

Jonny "Me You" Senior Member Join Date: March 2004 Location: Canada Posts: 2,863
Here's the final word on Iron man. There seems to be a lot of confusion since word about "defective" discs. So here we go, the review copies of the Blu Ray had a problem with the audio and wouldn't play. The retail version of the movie IS COMPLETELY NOT AFFECTED.

What's going on with the long load times, is the fault of Blu Ray Live and affects only those with Sony Players. It seems the player tries to download the Live content upon first booting up the disc and the Paramount servers have been so overwhelmed it crashed. Apparently most of the problems are fixed now. But if you still can't load the disc, turn off live.

THE DISCS ARE FINE!

Quick Reply 

Message Enter the message here then press submit. The username, password and message are required. Please make the message constructive, you are fully responsible for the legality of anything you contribute. Terms & conditions apply.
Not Registered?
Forgotten Details?